Resolved
This incident has been resolved. Thank you for your patience.
Monitoring
We have resolved the incident and are monitoring for further issues.
Investigating
We are aware of ongoing degraded performance in the provider portal and delays in case ingestion and processing. We are looking into the issue.