Resolved
This incident has been resolved. Thank you for your patience.
Monitoring
A background process started in the Provider Portal caused increased CPU usage on the underlying database, leading to degraded performance. We have rolled back the affected code and are monitoring any further impact.